intoDNS: DNS kayıtları, DNS Raporu, e-posta sunucuları ve alan adı yapılandırmalarınızı saniyeler içinde detaylı analiz eden kapsamlı kontrol ve doğrulama aracıdır.
Analiz Özeti: ✓ 42 Başarılı
NS Kayıt Sonuçları
DurumTest AdıBilgi
✓Domain NS KayıtlarıDNS sunucularından domain için NS kayıtları:
ns2.google.com. ( 216.239.34.10 ) TTL=340675
ns3.google.com. ( 216.239.36.10 ) TTL=340675
ns4.google.com. ( 216.239.38.10 ) TTL=340675
ns1.google.com. ( 216.239.32.10 ) TTL=340675
✓TLD Kök DNS Sorgusuİyi. 4 ad sunucusu mevcut
✓NS Sunucu Doğrulamasıİyi. Parent zone'dan GLUE kayıtları tutarlı. GLUE gerektiren NS kayıtları varsa doğru çözümleniyor.
✓NS İsim Geçerliliğiİyi. 4 kayıt bulundu. Tüm NS kayıtlarınız geçerli hostname formatında ve IP adreslerine çözümlenebiliyor.

1. ns2.google.com. → 216.239.34.10 (TTL: 340675s)
2. ns3.google.com. → 216.239.36.10 (TTL: 340675s)
3. ns4.google.com. → 216.239.38.10 (TTL: 340675s)
4. ns1.google.com. → 216.239.32.10 (TTL: 340675s)
✓Çoklu NS Analizi (RFC2182)İyi. RFC2182 bölüm 5'e göre en az 2, en fazla 7 NS kaydınız olmalı. 4 NS kaydınız var, bu kabul edilebilir.
SOA Sonuçları
DurumTest AdıBilgi
✓NS'ler aynı SOA seri numarasına sahipTamam. Tüm isim sunucularınız aynı SOA seri numarasına sahip: 1014560774
✓Birincil Nameserver (MNAME)Tamam. ns1.google.com. birincil isim sunucusu olarak listeleniyor.
•Seri NumarasıSOA seri numarası: 1014560774.
Önerilen format YYYYMMDDnn'dir (örn: 2024010101).
!Yenileme DeğeriSOA REFRESH değeriniz: 900. Bu değer çok düşük olabilir. Normalde 3600 (1 saat) veya üzeri önerilir.
Secondary sunucular bu sürede bir primary sunucuyu kontrol eder.
✓Tekrar Deneme DeğeriSOA RETRY değeriniz: 900. İyi görünüyor.
Primary sunucu erişilemezse 15 dakikada bir tekrar dener.
!Sona Erme DeğeriSOA EXPIRE değeriniz: 1800 (30 dakika). Bu değer çok düşük olabilir. Önerilen minimum: 1 hafta.
Primary sunucuya erişilemezse secondary sunucular bu süre sonra zone'u geçersiz sayar.
✓Minimum TTLSOA MINIMUM TTL değeriniz: 60. Bu, negatif önbellekleme için makul bir değer gibi görünüyor.
Bulunamayan kayıtlar 1 dakika boyunca önbelleklenir.
•SOA KaydıSOA kaydı şudur:

Birincil isim sunucusu: ns1.google.com.
Yönetici E-posta adresi: dns-admin@google.com.
Seri numarası: 1014560774
Yenileme: 900
Yeniden deneme: 900
Süre sonu: 1800 (30 dakika)
Varsayılan TTL: 60
!SOA Tutarlılık KontrolüUyarı. Retry (900s) Refresh'ten (900s) küçük olmalıdır.
MX Sonuçları
DurumTest AdıBilgi
✓MX Kayıtlarıİsim sunucularınız aynı MX kayıtlarını bildiriyor gibi görünüyor. Bu test, eksik bildirilen MX kayıtlarını ve aynı hostname ait farklı IP'leri kontrol eder.
✓Farklı İsim Sunucularında Farklı MX Kayıtlarıİsim sunucularınız aynı MX kayıtlarını bildiriyor gibi görünüyor. Bu test, eksik bildirilen MX kayıtlarını ve aynı hostname ait farklı IP'leri kontrol eder.
✓MX İsim Geçerliliğiİyi. MX kayıtlarınızda geçersiz bir hostname tespit edilmedi.
✓MX IP'leri Genelİyi. Tüm MX kayıtlarınız genel IP'leri kullanıyor.
✓MX CNAME Kontrolüİyi. MX kayıtlarınız için CNAME sorunu yok.
✓MX A Kaydı Doğrudan Eşleme TestiMX kayıtları doğrudan bir A kaydına işaret ediyor, dolaylı bir CNAME yönlendirmesi yok. Bu, e-posta teslimatında gecikme veya hataları önler ve DNS yapılandırmasının doğru olduğunu gösterir.
✓MX IP Değilİyi. Tüm MX kayıtlarınız ana bilgisayar adlarıdır.
!MX Kayıt SayısıUyarı: Alan adınızın sadece 1 MX kaydı var. Tek bir arıza noktasına sahip olmamanız için dikkatli olmalısınız, bu postanın kaybolmasına neden olabilir.
✓Eşleşmeyen MX Aİyi. MX kayıtlarınız için farklı IP'ler tespit edilmedi.
✓Yinelenen MX A Kayıtlarıİyi. MX kayıtlarınız için yinelenen IP'ler bulunamadı. Bu iyi bir şey.
✓Reverse MX A Kayıtları (PTR)Reverse (PTR) kayıtları:
142.251.127.26 → smtp.google.com
Tüm IP'leriniz için reverse (PTR) kayıtları var, bu iyi bir şey.
•SPF KaydıSPF kayıtları bulundu:
google.com: v=spf1 include:_spf.google.com ~all

SPF Analizi:
google.com için SPF kaydı (softfail mod ~all). Daha sıkı güvenlik için -all kullanmayı düşünün.
A Kayıtları
DurumTest AdıBilgi
✓A Kaydı 1google.com. → 172.217.168.142 TTL=6s
✓ Genel IP adresi
PTR: www.google.com
•IPv4 ÖzetiToplam 1 IPv4 adresi bulundu. Web sitesi bu adresler üzerinden erişilebilir.
✓AAAA Kaydı 1 (IPv6)google.com. → 2a00:1450:4002:408::200e TTL=270s
✓ IPv6 desteği mevcut
✓Web ErişilebilirlikWeb sitesi erişilebilir durumda. HTTP ve HTTPS protokolleri test edilebilir.
ℹ Ping testi yapabilir veya traceroute ile ağ yolunu inceleyebilirsiniz.
•Sunucu KonumuIP adreslerinin coğrafi konumu ve ISP bilgileri 3. parti servislerde sorgulanabilir.
IP Sorgulama: 172.217.168.142
•DNS YayılımıDNS kayıtlarının dünya genelinde yayılım durumu kontrol edilebilir.
Global DNS Yayılımını Kontrol Et
WWW Sonuçları
DurumTest AdıBilgi
✓WWW A Kaydıwww.google.com, şu IP adres(ler)ine yönleniyor: 142.251.155.119, 142.251.151.119, 142.251.150.119, 142.251.152.119, 142.251.157.119, 142.251.156.119, 142.251.153.119, 142.251.154.119. Bu bağlantı için iyi.
TTL: 298 saniye
•WWW CNAMEwww.google.com için CNAME kaydı bulunamadı.
✓IPv6 Desteği (AAAA)www.google.com için IPv6 (AAAA) kaydı bulundu: 2001:4860:482b:7700::, 2001:4860:4829:7700::, 2001:4860:4826:7700::, 2001:4860:4827:7700::, 2001:4860:4828:7700::, 2001:4860:482d:7700::, 2001:4860:482a:7700::, 2001:4860:482c:7700::. Modern ağlar için iyi.
DNS Sorgu Sonuçları
DurumTest AdıBilgi
✓Recursive Sorgu Kontrolü
✅ İyi. DNS sunucularınız recursive sorguları desteklemiyor.
✅ Tüm DNS sunucularınız recursive sorgulara yanıt vermiyor, bu güvenlik açısından iyi.
🛡️ Güvenli sunucular
216.239.34.10, 216.239.36.10, 216.239.38.10, 216.239.32.10
✓GLUE Kayıt Tutarlılığıİyi. Parent zone'dan GLUE kayıtları tutarlı. GLUE gerektiren NS kayıtları varsa doğru çözümleniyor.
✓NS için GLUE Analiziİyi. NS kayıtlarınız için GLUE kayıtları mevcut.
ns2.google.com [216.239.34.10], ns3.google.com [216.239.36.10], ns4.google.com [216.239.38.10], ns1.google.com [216.239.32.10]
✓Uyumsuz NS Kayıtlarıİyi. Tüm NS sunucuları aynı NS kayıtlarına sahip.
Tüm yetkili DNS sunucularınız aynı NS kayıt listesini döndürüyor, bu tutarlılık için iyi.
✓DNS Sunucu Yanıt Kontrolüİyi. Tüm DNS sunucularınız yanıt veriyor.
Parent sunucular tarafından listelenen tüm DNS sunucularınız DNS sorgularına yanıt veriyor.
✓NS İsim Geçerliliğiİyi. Tüm NS kayıtlarınız geçerli ve çözümlenebilir.
Tüm NS kayıtlarınız geçerli hostname formatında ve IP adreslerine çözümlenebiliyor.
✓Çoklu NS Analizi (RFC2182)İyi. RFC2182 bölüm 5'e göre en az 2, en fazla 7 NS kaydınız olmalı. 4 NS kaydınız var, bu kabul edilebilir.
✓Lame Sunucu Kontrolüİyi. Tüm NS sunucularınız yetkili.
Parent sunucular tarafından listelenen tüm NS sunucularınız domain için yetkili yanıtlar veriyor, lame sunucu yok.
✓Eksik NS Parent Kontrolüİyi. Tüm parent NS kayıtları domainde de mevcut.
Parent sunucular tarafından bildirilen tüm NS kayıtları domain'in kendi NS kayıtlarında da bulunuyor.
✓Eksik NS Raporlama Kontrolüİyi. Tüm domain NS kayıtları parent'ta da mevcut.
Domain'in kendi NS kayıtları parent sunucular tarafından da bildiriliyor.
✓Domain CNAME Kontrolü (RFC1912/RFC2181)İyi. Domain CNAME kaydına sahip değil.
RFC1912 2.4 ve RFC2181 10.3'e göre domainler CNAME kaydına sahip olmamalı. Bu kurala uyuluyor.
✓NS CNAME Kontrolü (RFC1912/RFC2181)İyi. NS kayıtlarınız CNAME değil.
RFC1912 2.4 ve RFC2181 10.3'e göre NS kayıtları CNAME olmamalı. Bu kurala uyuluyor.
✓Farklı Subnet Analiziİyi. NS sunucularınız muhtemelen 4 farklı alt ağda.
NS sunucularının farklı alt ağlarda olması tek nokta arıza riskini azaltır.
✓Public IP Analiziİyi. NS IP adreslerinizin çoğu genel.
NS sunucularınızın IP adresleri internetten erişilebilir.
✓TCP Bağlantı Desteğiİyi. DNS sunucularınız TCP bağlantılarını destekliyor.
DNS sunucularınız TCP bağlantılarını kabul ediyor. Bu büyük DNS yanıtları için gereklidir.
•Farklı AS AnaliziAS numaraları belirlenemedi. AS analizi mevcut değil.